import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(Andalucia).*$\n\n\n\n\n\n";
final String string = "04001#Almeria#Almería#AL#Andalucia#AN#ES\n"
+ "04002#El Palmer#Almería#AL#Andalucia#AN#ES\n"
+ "0400#Almeria#Almería#AL#Andalucia#AN#ES\n"
+ "04003#Almeria#Almería#AL#Andalucia#AN#ES\n"
+ "04004#Almeria#Almería#AL#Andalucia#AN#ES";
final String subst = "\\1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}