package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(Andalucia).*$
`)
var str = `04001#Almeria#Almería#AL#Andalucia#AN#ES
04002#El Palmer#Almería#AL#Andalucia#AN#ES
0400#Almeria#Almería#AL#Andalucia#AN#ES
04003#Almeria#Almería#AL#Andalucia#AN#ES
04004#Almeria#Almería#AL#Andalucia#AN#ES`
var substitution = "\1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}