use strict;
my $str = '04001#Almeria#Almería#AL#Andalucia#AN#ES
04002#El Palmer#Almería#AL#Andalucia#AN#ES
0400#Almeria#Almería#AL#Andalucia#AN#ES
04003#Almeria#Almería#AL#Andalucia#AN#ES
04004#Almeria#Almería#AL#Andalucia#AN#ES';
my $regex = qr/^.*(Andalucia).*$
/mp;
my $subst = '\\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";