#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*(Andalucia).*$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sString = "04001#Almeria#Almería#AL#Andalucia#AN#ES" & @CRLF & _
"04002#El Palmer#Almería#AL#Andalucia#AN#ES" & @CRLF & _
"0400#Almeria#Almería#AL#Andalucia#AN#ES" & @CRLF & _
"04003#Almeria#Almería#AL#Andalucia#AN#ES" & @CRLF & _
"04004#Almeria#Almería#AL#Andalucia#AN#ES"
Local $sSubst = "\1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)