re = /^.*(Andalucia).*$
/m
str = '04001#Almeria#Almería#AL#Andalucia#AN#ES
04002#El Palmer#Almería#AL#Andalucia#AN#ES
0400#Almeria#Almería#AL#Andalucia#AN#ES
04003#Almeria#Almería#AL#Andalucia#AN#ES
04004#Almeria#Almería#AL#Andalucia#AN#ES'
subst = '\\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result