# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z]*) ([a-zA-Z?]*) ([A-Za-z]*) => ([a-zA-Z0-9_]*)\?\.([a-zA-Z]*);/$1 $2 $3 { get { return $4 == null ? ($2)null : $4.$5; }}/gim;t' <<< "public string ClassOfUse => _quote?.ClassOfUse;
public bool? IsNcdGranted => _quote?.IsNcdGranted;"