import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z]*) ([a-zA-Z?]*) ([A-Za-z]*) => ([a-zA-Z0-9_]*)\\?\\.([a-zA-Z]*);";
final String string = "public string ClassOfUse => _quote?.ClassOfUse;\n"
+ "public bool? IsNcdGranted => _quote?.IsNcdGranted;";
final String subst = "$1 $2 $3 { get { return $4 == null ? ($2)null : $4.$5; }}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}