using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]*) ([a-zA-Z?]*) ([A-Za-z]*) => ([a-zA-Z0-9_]*)\?\.([a-zA-Z]*);";
string substitution = @"$1 $2 $3 { get { return $4 == null ? ($2)null : $4.$5; }}";
string input = @"public string ClassOfUse => _quote?.ClassOfUse;
public bool? IsNcdGranted => _quote?.IsNcdGranted;";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}