# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-z]*) ([a-zA-Z?]*) ([A-Za-z]*) => ([a-zA-Z0-9_]*)\?\.([a-zA-Z]*);"
test_str = ("public string ClassOfUse => _quote?.ClassOfUse;\n"
"public bool? IsNcdGranted => _quote?.IsNcdGranted;")
subst = "$1 $2 $3 { get { return $4 == null ? ($2)null : $4.$5; }}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.