use strict;
my $str = 'public string ClassOfUse => _quote?.ClassOfUse;
public bool? IsNcdGranted => _quote?.IsNcdGranted;';
my $regex = qr/([a-z]*) ([a-zA-Z?]*) ([A-Za-z]*) => ([a-zA-Z0-9_]*)\?\.([a-zA-Z]*);/imp;
my $subst = '$1 $2 $3 { get { return $4 == null ? ($2)null : $4.$5; }}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";