$re = '/([a-z]*) ([a-zA-Z?]*) ([A-Za-z]*) => ([a-zA-Z0-9_]*)\?\.([a-zA-Z]*);/im';
$str = 'public string ClassOfUse => _quote?.ClassOfUse;
public bool? IsNcdGranted => _quote?.IsNcdGranted;';
$subst = "$1 $2 $3 { get { return $4 == null ? ($2)null : $4.$5; }}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;