re = /([a-z]*) ([a-zA-Z?]*) ([A-Za-z]*) => ([a-zA-Z0-9_]*)\?\.([a-zA-Z]*);/im
str = 'public string ClassOfUse => _quote?.ClassOfUse;
public bool? IsNcdGranted => _quote?.IsNcdGranted;'
subst = '$1 $2 $3 { get { return $4 == null ? ($2)null : $4.$5; }}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result