#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\@(((\w+.*-*)+)?\w+)(:\d+)(:\w+)"
Local $sString = "@CORA-PC:1111:databasename" & @CRLF & _
"@111.111.1.111:111:databasename" & @CRLF & _
"@CORA-PC:1111:database=name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")