re = /\@(((\w+.*-*)+)?\w+)(:\d+)(:\w+)/
str = '@CORA-PC:1111:databasename
@111.111.1.111:111:databasename
@CORA-PC:1111:database=name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end