package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\@(((\w+.*-*)+)?\w+)(:\d+)(:\w+)`)
var str = `@CORA-PC:1111:databasename
@111.111.1.111:111:databasename
@CORA-PC:1111:database=name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}