const regex = /\@(((\w+.*-*)+)?\w+)(:\d+)(:\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\@(((\\w+.*-*)+)?\\w+)(:\\d+)(:\\w+)', 'g')
const str = `@CORA-PC:1111:databasename
@111.111.1.111:111:databasename
@CORA-PC:1111:database=name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}