$re = '/\@(((\w+.*-*)+)?\w+)(:\d+)(:\w+)/';
$str = '@CORA-PC:1111:databasename
@111.111.1.111:111:databasename
@CORA-PC:1111:database=name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);