using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\@(((\w+.*-*)+)?\w+)(:\d+)(:\w+)";
string input = @"@CORA-PC:1111:databasename
@111.111.1.111:111:databasename
@CORA-PC:1111:database=name";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}