// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\@(((\w+.*-*)+)?\w+)(:\d+)(:\w+)").unwrap();
let string = "@CORA-PC:1111:databasename
@111.111.1.111:111:databasename
@CORA-PC:1111:database=name";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}