#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "some text(?:(?!some text|two).)*two"
Local $sString = "some text blah blah one some text blah blah two."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)