using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"some text(?:(?!some text|two).)*two";
string substitution = @"$1";
string input = @"some text blah blah one some text blah blah two.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}