re = /some text(?:(?!some text|two).)*two/
str = 'some text blah blah one some text blah blah two.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result