const regex = /some text(?:(?!some text|two).)*two/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('some text(?:(?!some text|two).)*two', 'g')
const str = `some text blah blah one some text blah blah two.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);