use strict;
my $str = 'some text blah blah one some text blah blah two.';
my $regex = qr/some text(?:(?!some text|two).)*two/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";