$re = '/some text(?:(?!some text|two).)*two/';
$str = 'some text blah blah one some text blah blah two.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;