#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(struct\s*\b(?:.+?)\b\s*{(?:.|\s)+?})|(typedef\s*\bstruct\b\s*{(?:.|\s)+?}\s*\w+\s*)"
Local $sString = "struct Stock {" & @CRLF & _
"char symbol[10];" & @CRLF & _
"double32 price;" & @CRLF & _
"double32 open_price;" & @CRLF & _
"int64 volume;" & @CRLF & _
"};" & @CRLF & _
"" & @CRLF & _
"code ..." & @CRLF & _
"" & @CRLF & _
"struct Company {" & @CRLF & _
"string " & @CRLF & _
"name;" & @CRLF & _
"string description;" & @CRLF & _
"};" & @CRLF & _
"" & @CRLF & _
"more code ..." & @CRLF & _
"" & @CRLF & _
"typedef struct {" & @CRLF & _
"char symbol[10];" & @CRLF & _
"double price;" & @CRLF & _
"} Option;" & @CRLF & _
"" & @CRLF & _
"more code ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")