import re
regex = re.compile(r"(struct\s*\b(?:.+?)\b\s*{(?:.|\s)+?})|(typedef\s*\bstruct\b\s*{(?:.|\s)+?}\s*\w+\s*)")
test_str = ("struct Stock {\n"
"char symbol[10];\n"
"double32 price;\n"
"double32 open_price;\n"
"int64 volume;\n"
"};\n\n"
"code ...\n\n"
"struct Company {\n"
"string \n"
"name;\n"
"string description;\n"
"};\n\n"
"more code ...\n\n"
"typedef struct {\n"
"char symbol[10];\n"
"double price;\n"
"} Option;\n\n"
"more code ...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")