$re = '/(struct\s*\b(?:.+?)\b\s*{(?:.|\s)+?})|(typedef\s*\bstruct\b\s*{(?:.|\s)+?}\s*\w+\s*)/';
$str = 'struct Stock {
char symbol[10];
double32 price;
double32 open_price;
int64 volume;
};
code ...
struct Company {
string
name;
string description;
};
more code ...
typedef struct {
char symbol[10];
double price;
} Option;
more code ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);