using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(struct\s*\b(?:.+?)\b\s*{(?:.|\s)+?})|(typedef\s*\bstruct\b\s*{(?:.|\s)+?}\s*\w+\s*)";
string input = @"struct Stock {
char symbol[10];
double32 price;
double32 open_price;
int64 volume;
};
code ...
struct Company {
string
name;
string description;
};
more code ...
typedef struct {
char symbol[10];
double price;
} Option;
more code ...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}