// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(struct\s*\b(?:.+?)\b\s*{(?:.|\s)+?})|(typedef\s*\bstruct\b\s*{(?:.|\s)+?}\s*\w+\s*)").unwrap();
let string = "struct Stock {
char symbol[10];
double32 price;
double32 open_price;
int64 volume;
};
code ...
struct Company {
string
name;
string description;
};
more code ...
typedef struct {
char symbol[10];
double price;
} Option;
more code ...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}