import Foundation
let pattern = #"(struct\s*\b(?:.+?)\b\s*{(?:.|\s)+?})|(typedef\s*\bstruct\b\s*{(?:.|\s)+?}\s*\w+\s*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
struct Stock {
char symbol[10];
double32 price;
double32 open_price;
int64 volume;
};
code ...
struct Company {
string
name;
string description;
};
more code ...
typedef struct {
char symbol[10];
double price;
} Option;
more code ...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)