const regex = /(struct\s*\b(?:.+?)\b\s*{(?:.|\s)+?})|(typedef\s*\bstruct\b\s*{(?:.|\s)+?}\s*\w+\s*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(struct\\s*\\b(?:.+?)\\b\\s*{(?:.|\\s)+?})|(typedef\\s*\\bstruct\\b\\s*{(?:.|\\s)+?}\\s*\\w+\\s*)', 'g')
const str = `struct Stock {
char symbol[10];
double32 price;
double32 open_price;
int64 volume;
};
code ...
struct Company {
string
name;
string description;
};
more code ...
typedef struct {
char symbol[10];
double price;
} Option;
more code ...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}