#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\n\s?-\s?(.*)"
Local $sString = "Lorem ipsum." & @CRLF & _
"" & @CRLF & _
"- item 1" & @CRLF & _
"- item 2" & @CRLF & _
"- item 3" & @CRLF & _
"- item 4" & @CRLF & _
"" & @CRLF & _
"Dolores amet."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")