const regex = /\n\s?-\s?(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n\\s?-\\s?(.*)', '')
const str = `Lorem ipsum.
- item 1
- item 2
- item 3
- item 4
Dolores amet.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}