$re = '/\n\s?-\s?(.*)/';
$str = 'Lorem ipsum.
- item 1
- item 2
- item 3
- item 4
Dolores amet.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);