re = /\n\s?-\s?(.*)/
str = 'Lorem ipsum.
- item 1
- item 2
- item 3
- item 4
Dolores amet.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end