import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n\\s?-\\s?(.*)";
final String string = "Lorem ipsum.\n\n"
+ "- item 1\n"
+ "- item 2\n"
+ "- item 3\n"
+ "- item 4\n\n"
+ "Dolores amet.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}