# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\w+\s*='((?=http:\/\/www\.website\.com)[^']+)'/"$1"/sg;t' <<< "<img src='http://www.website.com/images/icons/main_icon.png' width='100' scalefit='1'>
<a href='http://www.website.com/page.php?variable1=a&variable2=b'>Click Here</a>
<form action='http://www.website.com/action.php?action=$action_type' method='post'>
<a href='http://example.net' title='WAAHT?''>HEI</a>"