$re = '~\b\w+\s*=\'((?=http://www\.website\.com)[^\']+)\'~s';
$str = '<img src=\'http://www.website.com/images/icons/main_icon.png\' width=\'100\' scalefit=\'1\'>
<a href=\'http://www.website.com/page.php?variable1=a&variable2=b\'>Click Here</a>
<form action=\'http://www.website.com/action.php?action=$action_type\' method=\'post\'>
<a href=\'http://example.net\' title=\'WAAHT?\'\'>HEI</a>';
$subst = "\"$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;