re = /\b\w+\s*='((?=http:\/\/www\.website\.com)[^']+)'/
str = '<img src=\'http://www.website.com/images/icons/main_icon.png\' width=\'100\' scalefit=\'1\'>
<a href=\'http://www.website.com/page.php?variable1=a&variable2=b\'>Click Here</a>
<form action=\'http://www.website.com/action.php?action=$action_type\' method=\'post\'>
<a href=\'http://example.net\' title=\'WAAHT?\'\'>HEI</a>'
subst = '"$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result