const regex = new RegExp('\\b\\w+\\s*=\\'((?=http://www\\.website\\.com)[^\\']+)\\'', 'sg')
const str = `<img src='http://www.website.com/images/icons/main_icon.png' width='100' scalefit='1'>
<a href='http://www.website.com/page.php?variable1=a&variable2=b'>Click Here</a>
<form action='http://www.website.com/action.php?action=\$action_type' method='post'>
<a href='http://example.net' title='WAAHT?''>HEI</a>`;
const subst = `"$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);