# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b\w+\s*='((?=http://www\.website\.com)[^']+)'"
test_str = ("<img src='http://www.website.com/images/icons/main_icon.png' width='100' scalefit='1'>\n"
"<a href='http://www.website.com/page.php?variable1=a&variable2=b'>Click Here</a>\n"
"<form action='http://www.website.com/action.php?action=$action_type' method='post'>\n"
"<a href='http://example.net' title='WAAHT?''>HEI</a>")
subst = "\"$1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.