import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\w+\\s*='((?=http://www\\.website\\.com)[^']+)'";
final String string = "<img src='http://www.website.com/images/icons/main_icon.png' width='100' scalefit='1'>\n"
+ "<a href='http://www.website.com/page.php?variable1=a&variable2=b'>Click Here</a>\n"
+ "<form action='http://www.website.com/action.php?action=$action_type' method='post'>\n"
+ "<a href='http://example.net' title='WAAHT?''>HEI</a>";
final String subst = "\"$1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}