use strict;
my $str = '<img src=\'http://www.website.com/images/icons/main_icon.png\' width=\'100\' scalefit=\'1\'>
<a href=\'http://www.website.com/page.php?variable1=a&variable2=b\'>Click Here</a>
<form action=\'http://www.website.com/action.php?action=$action_type\' method=\'post\'>
<a href=\'http://example.net\' title=\'WAAHT?\'\'>HEI</a>';
my $regex = qr~\b\w+\s*='((?=http://www\.website\.com)[^']+)'~sp;
my $subst = '"$1"';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";