import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\.{1,2}\\/|(?:[a-z]:)?[\\\\\\/])";
final String string = "C:\\hello world\n"
+ "test\n"
+ "/a/b/c\n"
+ "../x\n"
+ "./e\n"
+ "\\\\test\\a\\b\n"
+ "foobar\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}