$re = '/^(?=\.{1,2}\/|(?:[a-z]:)?[\\\\\/])/im';
$str = 'C:\\hello world
test
/a/b/c
../x
./e
\\\\test\\a\\b
foobar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);