import re
regex = re.compile(r"^(?=\.{1,2}\/|(?:[a-z]:)?[\\\/])", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("C:\\hello world\n"
"test\n"
"/a/b/c\n"
"../x\n"
"./e\n"
"\\\\test\\a\\b\n"
"foobar\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")