re = /^(?=\.{1,2}\/|(?:[a-z]:)?[\\\/])/im
str = 'C:\\hello world
test
/a/b/c
../x
./e
\\\\test\\a\\b
foobar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end