package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`( )( )*([^ ])`)
var str = `abc def ghi xyz`
var substitution = "$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}