const regex = /( )( )*([^ ])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( )( )*([^ ])', 'g')
const str = `abc def ghi xyz`;
const subst = `$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);